HOLLOW SQUARE PATTERN

   Consider the following I/O samples.


SAMPLE INPUT:  4

SAMPLE OUTPUT:   
                                  * * * * 

                                          *       *                         

                                          *       *   

                                                    * * * *

            
C PROGRAM:  

#include <stdio.h>
int main()
{
    int row,col,n;
    scanf("%d",&n);
    for(row=1; row<=n; row++)
    {
        for(col=1; col<=n; col++)
        {
            if(row==1 || row==n || col==1 || col==n)
                printf("* ");
            else
                printf("  ");
        }
       printf("\n");
    }
    return 0;

}


OUTPUT:

 




The given source code in C program is short and simple to understand. The source code is well tested in DEV-C++ and is completely error free. 

If you have any feedback about this article and want to improve this, please comment in the comment section.

 

Comments

Popular posts from this blog

HOLLOW INVERTED PYRAMID STAR

HOLLOW PYRAMID STAR PATTERN

INNER REDUCING PATTERN