OCTAL TO DECIMAL CONVERSION
Consider the following I/O samples.
SAMPLE INPUT : 32
SAMPLE OUTPUT: 26
#include <stdio.h>
int main()
{
long int n, base=1, rem, ans=0;
scanf("%ld",&n);
while(n)
{
rem=n%10;
ans=ans+rem*base;
base=base*8;
n=n/10;
}
printf("%ld",ans);
return 0;
}
OUTPUT:
The given source code in C program is short and simple to understand. The source code is well tested in DEV-C++ and is completely error free.
If you have any feedback about this article and want to improve this, please comment in the comment section.
C PROGRAM:
#include <stdio.h>
int main()
{
long int n, base=1, rem, ans=0;
scanf("%ld",&n);
while(n)
{
rem=n%10;
ans=ans+rem*base;
base=base*8;
n=n/10;
}
printf("%ld",ans);
return 0;
}
If you have any feedback about this article and want to improve this, please comment in the comment section.
Comments
Post a Comment